Having a problem with the forums?

If you are having a problem with the forums, try clicking on the "FAQ" link at the top of the page first. If that doesn't work, stop in here for help. Suggestions for site improvement are welcomed. For the love of Lennin, if you have a tech question about your rig, put it in "The Order of the Greasy Wrench" section below, not here.
Forum rules
This is the place to report problems with the forums, ask for help with the fourms and test posts. Techincal Support for Ural and Dnepr motorcycles is in the Hammerin' & Wrenchin' section.
Locked
User avatar
JohnBG
General Secretary
General Secretary
Posts: 15805
Joined: Tue Jul 17, 2007 4:12 pm
Location: Deltona, FL & Franklin, NC USA
Contact:

Having a problem with the forums?

Post by JohnBG » Tue Jul 17, 2007 11:24 pm

Try using the "FAQ" link at the top of the page first. That should answer about 95% of all of the common questions.

To register as a member, click on the "Register" link at the top of the page.

If you are still having a problem, post it here and we'll try to fix it.

Thanks,
John Grocke aka "JohnBG"
Site Administrator - sovietsteeds.com

Current Rides:
'06 Ural Raven - "Vorona"
'09 Kawasaki KLR650 - "Madea"

History:
'98.5 Ural Tourist - "Valentina" - Gone but not forgotten.
2002 Harley Road King FLHPI
1997 Harley Electra Glide FLHTPI
Honda Nighthawk 650 from the mid-80's
1980 Suzuki RM125T
1970 Honda CL100

Love is the feeling you get when you like something as much as your motorcycle.” ― Hunter S. Thompson

Locked