g-414 dynamo revival ?

Are ya having a problem with your rig? We'll try to help. Share your tech tips and experiences here. Dr. Billy Glaser, author of the "Unofficial 750 Ural Service Manual" site myural.com, is moderating this section.
Forum rules
Here is the place for you to ask questions about or share your experiences about servicing or repairing your Ural or Dnepr. Please post topics concering modifications or accesories in the "Modifications and Acessories" section. Please post oil related questions in the "Oil Threads" section.
Post Reply
rune2650
New Member
New Member
Posts: 5
Joined: Mon Jul 01, 2019 5:37 pm
Location: Denmark

g-414 dynamo revival ?

Post by rune2650 » Thu Jan 30, 2020 7:21 pm

so, my Dnepr k750 stoped charging the battery, the electronic charging relay from jan-buchwald.dk isn't something I can figure out how to see if it still works, but the dynamo is what that's confuses me.

i have had it pulled apart, cleaned the brushes, cleaned the contacts on the commutator, checked it for shorts, checked the windings for any shorts or brakeges and resolderes them back in there exact locations that they where in before, checked the field winding, and everything checks out fine.

i even tried to "flash" the generator, and no mater what I do, I can only get 0.15v DC when spinning the dam thing at 750rpm (like in this video: https://www.youtube....h?v=7n8gZ4cyesw )

what is it that im doing wrong ? or perhaps might have overlooked

User avatar
jaybird
Order of Suvarov
Order of Suvarov
Posts: 3071
Joined: Thu Jul 01, 2010 4:41 am
Location: The foothills of the Forked River Mountains, West Barnegat NJ (Do It In The Pines!) 08005

Re: g-414 dynamo revival ?

Post by jaybird » Mon Feb 10, 2020 3:20 am

Bump.

Happy trails,
Jaybird
2005 Gear-Up, Mr. Nat_ural 108,000+ Kilometers and counting
2013 Retro, Black beauty, AKA Lucky "13"
1995 Olive Tourist
1975 Enfield Diesel Bullet
2008 Enfield Bullet 500
1974 BMW R 75/6
Etc.

User avatar
cateyetech
Hero of the Soviet Union - 2020
Hero of the Soviet Union - 2020
Posts: 1558
Joined: Sat Jan 05, 2013 8:23 am
Location: 72801 Russellville Arkansas
Contact:

Re: g-414 dynamo revival ?

Post by cateyetech » Mon Feb 10, 2020 7:49 am

Hey rune
I don't know your exact generator
but on the old bikes I work on
a shorted armature is common
and needs to be checked with a growler
to tell if it shorted out
It sounds like you have covered everything else

Good luck :foilhead:

rune2650
New Member
New Member
Posts: 5
Joined: Mon Jul 01, 2019 5:37 pm
Location: Denmark

Re: g-414 dynamo revival ?

Post by rune2650 » Mon Mar 09, 2020 7:25 am

I finally managed to get the dynamo to work again, it turned out to be one of the coals that didn't deliver power correctly, it seemed to be where the wire was inserted into the coal, but after changing that, I got around 4.3V DC out of the dynamo, when spinning it at 750rpm, and after I paired it with a new used mechanical voltage regulator (original model for my bike, PP302), the bike charges the battery with no problem :D

Post Reply